IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Error Starting Dedicated Server
Semorph
post Jan 10 2008, 04:36 PM
Post #1


Mapper
*

Group: Members
Posts: 17
Joined: 24-November 07
From: Western MA
Member No.: 6,759



hi, im getting an error starting a dedicated server on linux redhat enterprise 4 i686

LoadLibrary failed on ./bg/dlls/bg_i386.so: libstdc++.so.6: cannot handle TLS data
Host_Error: Couldn't get DLL API from ./bg/dlls/bg_i386.so!
FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from ./bg/dlls/bg_i386.so!
Thu Jan 10 10:34:31 CST 2008: Server restart in 10 seconds

i have everything freshly installed and no admin mods

thx


--------------------
- Semorph
Go to the top of the page
 
+Quote Post
gecko
post Jan 10 2008, 05:29 PM
Post #2


King Gecko of 1.0F Dev
Group Icon

Group: Admin
Posts: 625
Joined: 20-April 04
Member No.: 2,511



Can you provide more details (gcc++ version, kernel version), and have you tried to compile the .so yourself?
Go to the top of the page
 
+Quote Post
3DDEATH
post Jan 10 2008, 09:21 PM
Post #3


Major
*******

Group: Members
Posts: 936
Joined: 26-March 04
Member No.: 2,430



here is the .so file for linux bg1

http://webzoom.freewebs.com/3dbattlefield/bg_i386.zip


--------------------




QUOTE (gRanTeLbArT @ Aug 25 2007, 02:47 PM) *
I will tell you what I think, this is horrible. Like all the other remakes of BG1 maps. There is a reason why we do not do that in any form. Do not bother to remake old bg1 maps. BG1 was a totally different game as draco pointed out and the maps are not going to work out on BG2.






Rejoice in thy youth,soon it will be gone
Go to the top of the page
 
+Quote Post
Semorph
post Jan 11 2008, 05:11 AM
Post #4


Mapper
*

Group: Members
Posts: 17
Joined: 24-November 07
From: Western MA
Member No.: 6,759



Operating system Linux
Service Status Click to View
Kernel version 2.6.9-67.ELsmp
Machine Type i686
Apache version 1.3.37 (Unix)
PERL version 5.8.8
Path to PERL /usr/bin/perl
Path to sendmail /usr/sbin/sendmail
Installed Perl Modules Click to View
PHP version 4.4.7
MySQL version 4.1.22-standard
cPanel Build 11.16.0-STABLE 18450
Theme cPanel X v2.6.0

its on cpanel obviously, so im not where to find the gcc++ version and im not very familiar with linux.
i haven't compiled it my self because i dont know how and im not sure it can be done with cpanel.
all tho if it can, i can figure it out.


--------------------
- Semorph
Go to the top of the page
 
+Quote Post
gecko
post Jan 11 2008, 05:31 AM
Post #5


King Gecko of 1.0F Dev
Group Icon

Group: Admin
Posts: 625
Joined: 20-April 04
Member No.: 2,511



Run the command 'gcc --version'

You should see something like this:
CODE
wtfgecko@medusa ~ $ gcc --version
gcc (GCC) 3.4.6 (Gentoo 3.4.6-r1, ssp-3.4.5-1.0, pie-8.7.9)


You can try this one, Its one I compiled myself:
http://mirror.bgmod.com/bg1/1.0f/bg_i386.so

What command are you using to start the server?
Go to the top of the page
 
+Quote Post
Semorph
post Jan 11 2008, 05:33 PM
Post #6


Mapper
*

Group: Members
Posts: 17
Joined: 24-November 07
From: Western MA
Member No.: 6,759



ok, i tried your version and im still getting the same error
my gcc++ version is 'gcc (GCC) 3.4.6 20060404 (Red Hat 3.4.6-9)'
and the command im using is './hlds_run -game bg +maxplayers 24 -ip 74.52.93.178 -port 27016 +map bg_ruin'

thx


--------------------
- Semorph
Go to the top of the page
 
+Quote Post
hairypotter
post Jan 11 2008, 05:57 PM
Post #7


Part of the Big Five conspiracy
Group Icon

Group: Retired Team Members
Posts: 983
Joined: 23-June 05
From: New Mexico
Member No.: 3,585



I thought HL1 code required GCC 2 for Linux?


--------------------
fa⋅ce⋅tious  [fuh-see-shuhs] –adjective
1. not meant to be taken seriously or literally: a facetious remark.
2. amusing; humorous.
3. lacking serious intent; concerned with something nonessential, amusing, or frivolous: a BG2 developer.


Go to the top of the page
 
+Quote Post
Semorph
post Jan 11 2008, 06:23 PM
Post #8


Mapper
*

Group: Members
Posts: 17
Joined: 24-November 07
From: Western MA
Member No.: 6,759



is there a way to get an older version? and gecko has the same version i do, can gecko run a dedicated server from it?

This post has been edited by Semorph: Jan 11 2008, 06:26 PM


--------------------
- Semorph
Go to the top of the page
 
+Quote Post
hairypotter
post Jan 12 2008, 01:16 AM
Post #9


Part of the Big Five conspiracy
Group Icon

Group: Retired Team Members
Posts: 983
Joined: 23-June 05
From: New Mexico
Member No.: 3,585



Well..... not if it's compiled with GCC 3.X.X, there's a binary incompatability thingy... whatever.
If you have debian I guess you could just apt-cache search GCC2 or something. For a Redhat distro... yum search gcc2 or gcc-2 I don't know. Then yum install (whatever the package is actually called)

Edit: yeah I can still find gcc 2.95 on the repository. So just install then and set it up. You should know the rest.

This post has been edited by hairypotter: Jan 12 2008, 01:17 AM


--------------------
fa⋅ce⋅tious  [fuh-see-shuhs] –adjective
1. not meant to be taken seriously or literally: a facetious remark.
2. amusing; humorous.
3. lacking serious intent; concerned with something nonessential, amusing, or frivolous: a BG2 developer.


Go to the top of the page
 
+Quote Post
gecko
post Jan 12 2008, 02:07 AM
Post #10


King Gecko of 1.0F Dev
Group Icon

Group: Admin
Posts: 625
Joined: 20-April 04
Member No.: 2,511



You *don't* need GCC2 to run or compile bg1, GCC3 runs and works just fine, I run all my servers on GCC3, and the linux release was compiled on it.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 12th December 2019 - 02:51 PM